Le topic qui Excel

Yo les gars !

Bon ça fait 3 ans que je n’ai pas ouvert Excel sauf pour faire des sommes et des moyennes donc je ne sais plus faire grand chose :sac:

La Situation :
J’ai 15 events qui se déroulent ( les 15 lignes), pour chaque event il y a des conditions qui sont respectées ( ou non).
=> Une fois l’event terminé, vient le résultat, 4 possibilités ( avec des corrélations mais je pense qu’on s’en fous. Si 1 est valide alors 2 est invalide. Si 3 est valide alors 2 est valide et si 4 est valide alors 3 est valide).

Mon but ici est de vérifier l’impact des conditions sur le résultat. Par exemple si la Colonne 2 = 1 alors j’aimerai savoir si le résultat 1, 2 ou 3 est atteint ( le but serait d’obtenir un pourcentage, en gros si Colonne 2 =1 alors on a 70% d’avoir le résultat 2).
Je croyais qu’un pauvre Recherchev allait suffire mais je ne sais plus trop comment il fonctionne :sac:, m’enfin sur Internet je peux trouver la réponse.

Maintenant ce que je voudrais faire dans le futur c’est définir une suite de condition et non plus une seule colonne.
Je m’explique, le but serait d’isoler les paires/triplets de conditions qui donnent par exemple plus de 80% de résultat pour le Résultat 2, c’est possible ça ? Par exemple si Colonne 2 et Colonne 3 valides alors on a 80% de chance d’avoir R2, 60% R3 et 20% R4.

Merci de votre aide, je n’ai même plus excel sur mon ordi perso, c’est la galère.

Ça fait 10 ans que je l’utilise et sache qu’il n’y a pas de honte à ne savoir faire que des sommes et des moyennes.

:juppe1:

Pour le reste je laisse les gens intelligents répondre :sac:

4 J'aimes

M’enfin moi je crois qu’il y a Maitrise d’Excel sur mon cv… je vais aller le virer :sac:

Besoin de vous !

Voici mon problème : j’ai une valeur, et je voudrais faire une vérification de présence dans une cellule contenant plusieurs valeurs.

Exemple :
Valeur à rechercher (case A2) : 800
Liste des valeurs (case A3) : 789, 800, 825

Je voudrais, dans une nouvelle cellule (A4 par exemple), retourner un booléen du genre : Si 800 est présent dans A3, alors retourner 1 sinon 0.

Des listes dans Excel :kaamelott2:

Nonetheless :

image

=SIERREUR(SI(TROUVE(A2;A3;1)>0;1;0);0)

1 J'aime

=SI(NB.SI(A2;“800”);1;0)

1 J'aime

Merci messieurs !

Qu’est ce que tu préconises à la place des listes ?

Une valeur par case, avec la fonction convertir je pense :sweat_smile:

Merci de votre aide :sac:

Ah ok la liste correspondait à un choix dans une seule et même case.
C’est pas le mieux en effet :sarko3:

1 J'aime

Nouvel demande :

J’ai 1 tableau de deux colonnes. Ce tableau représente une range.
Je voudrais à partir de la range fournie en paramètre (VBA), par exemple : A1:B10, pouvoir récupérer la valeur B1 de la range.

Le but est de mettre en place une mise en forme conditionnelle en passant en paramètre la range.

Du coup, j’ai déjà la formule de base, qui est B1-A1<>0. Mais je voudrais la rendre dynamique.

Merci d’avance.

J’ai rien compris.

C’est bon au final. J’ai cherché à me complexifier la tâche.

Je construis un fichier excel, j’en suis à mon 25ème onglet :obama2:

2 J'aimes

:sac:

C’est plutôt bon signe, ça montre que tu divises bien les tables pour bien structurer les données :macron5:

Je fais un tableau en ce moment mais je ne trouve pas de fonction pour compter les cases selon les couleurs.

Excel
(Extrait de mon tableau)

Par exemple j’aurais aimé savoir directement combien j’ai de cases en vert, en jaune, en rouge et en blanc.
C’est faisable avec =NB_SI_COULEUR (je viens de trouver ça) ?

Via un TCD, tu n’as pas le filtre couleur ?

Tu as une couleur unique par ligne? Si oui pour contourner tu fait un filtre par couleir et tu rajoute une colonne avec un code couleur (genre V pour vert, R pour rouge etc…) tu colle chaque valeur a toute les lignes de chaque couleur pour chaque filtre et puis tu fais un countif sur ta nouvelle colonne. Puis tu multiplie par ton nombre de colonne sauf celle de ton code couleur?

Excel
J’ai réussi c’est bon :sac:

2 J'aimes