Le topic qui Excel


#41

J’ai trouvé en fait, on peut directement faire des graphiques croisés dynamiques !


#42

Les mecs,

vous savez si je peux faire une sort de barre de progression via Excel ?

En gros j’ai 680 ref et je voudrais qu’à chaque fois que je met en couleur une cellule, celle ci augmente ma barre de progression.


#43

Mise en forme conditionnelle > Barre de données :

Après pour compter les valeurs par couleur faut une macro, mais tu peux simplement te créer un colonne “valider” remplie avec la valeur à rajouter pour ton total de progression


#44

En fait je n’ai qu’une couleur.

J’explique un peu plus. J’ai fais sur un Excel un tableau regroupant les 680 vignettes Panini pour l’EURO 2016.

Je passe la case en vert une fois que j’ai la vignette. Mais je voudrais un truc qui puisse me dire ou j’en suis dans le total de l’album. Est ce que c’est possible selon toi ?


#45

Au pire tu fais une formule avec un %.


#46

Perso j’attaquerais le problème différemment :

Je créerais une colonne à côté de la colonne des joueurs. Dedans tu renseignes si tu as la carte ou non. Par exemple un “1” ou un “X”.
En bas de ta colonne, tu fais une formule nb.si(taplage;“1”). ça comptera le nombre de fois ou tu as une cellule qui correspond à une carte que tu as.

Après, tu fais une mise en forme conditionnelle sur ta colonne des joueurs dans laquelle tu demandes à prendre une couleur verte en fonction de la valeur “1” de la colonne d’à côté. Comme le lien ci dessous :

Si tu veux un truc propre, tu masques ta colonne de 1 et le tour est joué.


#47

Salut à tous. Je voulais savoir si y avait moyen dd remplir un tableau Excel puis de trier avec la colonne minute par exemple. Genre j ai 20 lignes 3colonnes une ville une distance et une j en sais rien, trier par rapport à la valeur de la colonne distange (ou minute) genre celles de 10 min puis celles de 11puis 13 et ca se met dans l ordre automatiquement…
si c est poss merci si c est incompréhensible désolé.


#48

Je pense que c’est possible, choisis le tableau, puis tri personnalisé en haut à droite et avise ?

C’est pas ultra clair non plus


#49

C’est assez simple oui. Il y a plusieurs endroits pour faire ca d’ailleurs. Le plus simple à expliquer ;

Ton tableau > Sélection de la colonne à trier > Clic droit sur la sélection > Trier > Choisir le tri > Bien penser à étendre la sélection > Voila !


[details=Avec images ;)]Ton tableau

Sélection de la colonne à trier ;

Clic droit sur la sélection ;

Bien penser à étendre la sélection, sinon il ne triera que la colonne sans corriger/actualiser les autres. ^^

Et c’est bon. ^^[/details]


#50

merci c est vraiment top !


#51

Comment savoir si j’ai des cellules qui se répètent ? Exemple dans mon cas : pleins de références de produits à la suite, comment je fais pour savoir le nombre exacte de chaque référence ?

Merci


#52

Utilise une formule NB.SI(Plage; référence) et t’auras le nombre de fois qu’apparaît la référence, si j’ai bien compris :wink:


#53

Merci !

Comment je fais pour supprimer les lignes doublons du coup et de remplacer la quantité par la nouvelle ?


#54

Tu peux faire un filtre sur ton tableau, et sur la colonne avec les références en doubles tu fais apparaître toutes celles que tu veux supprimer et/ou remplacer, et tu fais tes manips dessus.


#55

Ouais donc c’est manuel :no:

Merci en tout cas


#57

pas forcement.

Avec ton NB.SI, tu peux compter les occurences, et dans un nouvelle feuille (on va l’appeler table_nouvelle_valeur") tu met en première colonne l’ancienne valeur et dans la seconde la nouvelle (ça marche si c’est toujours remplacé par la même valeur à changer, par exemple 1 -> 2 et 2->3)
Ce qui donne, dans la colonne du NB.SI

=SI(NB.SI(cellule_a_checker)=1;cellule_a_checker;recherchev(cellule à checker, table_nouvelle valeur,2;FAUX))

Ne pas oublier de bien vérouiller avec F4 la référence à table_nouvelle valeur

Après si c’est pour des classements ou tu veux pas d’égalité et qu’il te mette une valeur supérieure/inférieure au lieu du doublon, t’as d’autres manip pour ça (que je peux détailler aussi si besoin)


#58

Le pb c’est que j’ai aussi une colonne quantité et j’aimerais savoir combien de quantités totales possèdent une même référence ?


#59

SOMME.PROD te fera ça ^^


#60

Je vois pas comment lol

Bon en triant de A à Z, j’arrive à les regrouper et je pourrais les compter à la main…


#61

=SOMMEPROD((C2:C1000)*(A2:A1000=“ZST01347”))

Ça te sommes toutes les quantités pour la référence en question.


Suivre @iunctisFR sur Twitter - Programme Partenaire amazon.fr : Amazon Prime - Amazon Prime Video - Amazon Audible