Le topic qui Excel


#122

Elle va être belle mon étude si tu passes pour un génie en interne :tommy:


#123

Tu connais INDEX(EQUIV) ?

Tu vas devenir leur dieu après ça :sac:


#124

j’ai lu vite fait, plusieurs fois quand même, toujours pas compris à quoi ça servait!

pour revenir à des choses plus terre à terre, comment fait-on des classes à intervalle manuel? genre <25, 25-49, 50-64, >65? (putain j’assume moyen de demander ça aux yeux de @douante alors que dans 4 jours je vais me présenter en face de lui en mode “expert qui va vous aider” haha ).

EDIT: Dans un TCD bien entendu


#125

Faut que t’attribue une classe d’âge à chaque valeur avant de faire ton TCD.

@Malko avait donné une bonne solution y a quelques mois :

Faut juste pas oublier de figer ta matrice source : RECHERCHEV($A1;$C$1:$D$20;2;VRAI)

C’est RECHERCHEV, en beaucoup plus puissant ^^

J’attends mon contrat de sous-traitance maintenant :harvey:


#126

Sinon il y a les conditions =SI

=SI(0<A1<15;“classeA”;SI(15<A1<30;“classeB”;SI(31<A1<45;“classeC”;SI(46<A1<60;“classeD”;“NonClassé”))))


#127

Ca fonctionne tant que tu n’as pas 150 classes différentes ça. Technique de roumain :no:


#128

Comme il en a que 4 ça devrait le faire :obama3: Surtout que je lui ai écrit la formule et qu’il a qu’à la copier coller :sac:


#129

Merci mais du coup je me suis démerdé avec un bon vieux “nb si.ens”, parce que il y’avait 2/3 conditions aussi, ça l’a bien fait.


#130

:lebron2:

Doudou, tu me déçois :hollande3:


#131

non mais si vous voulez aller pêcher le goujon à la dynamite allez-y :dsk:

Gardons les index equiv et les recherchev pour ce qui le mérite. Genre, mon tableau des stats des championnats des pronos :labrune:


#132

Mes Exceliens sûrs,

On m’a demandé un truc un peu coton. Déjà je pars d’un fichier brut d’environ 770 000 lignes (donc déjà les temps de chargement sont assez longs :no: ). A partir de ce fichier, moi et d’autres personnes avons extrait des lignes selon des critères définis pour faire des jeux de tests (pour l’industrialisation d’un reporting). Et du coup je dois contrôler si les jeux de tests respectent bien les règles mises en place. Donc sur ma base de travail (le gros fichier de 770 000 lignes) je dois pouvoir dire à quel jeu de test chaque ligne a été affectée. Alors si de base j’avais un identifiant unique par ligne le problème se poserait pas, mais c’est pas le cas.
J’ai essayé de bricoler un truc en regroupant pour chaque ligne tous les critères de selection par colonne mais parfois j’ai des cellules en #NA et par conséquent sur ma concaténation j’ai juste du #NA par moment.

Donc je suis en train de réfléchir, mais je vois pas trop comment m’en sortir sur le coup. :no:


#133

Tu pourrais vérifier les critères via du VBA ?

Ou rajouter une table intermédiaire où tu remplacerais les N/A par une valeur par défaut, comme ça tu n’aurais plus de soucis lors de la concaténation ?


#134

J’ai pas tout compris ce que tu voulais faire, mais dans le doute, le meilleur ami des erreurs de résultats de formules, c’est SIERREUR ^^


#135

Bah déjà tu vas voir le connard qui a pensé le fichier, et tu lui expliques que la prochaine fois, s’il prévoit pas une clé unique, tu le feras souffrir.

Vous avez beaucoup bossé dessus ? Tu peux pas insérer une clé unique et refaire les exports ? :sac:


#136

Au final vu que j’ai seulement 2 champs pour lesquels j’ai du #NA, j’ai créé deux colonnes de contrôles supplémentaires pour ces deux champs. Je pense m’en sortir avec ça du coup, même si ça va prendre un peu de temps (mon ordi est en souffrance). Du coup la formule a cette gueule là :

=SI(ET(AA42902=VRAI;AB42902=FAUX);CONCATENER(B42902;C42902;D42902;E42902;"#NA";I42902;J42902;K42902;L42902;M42902;N42902;O42902;P42902;Q42902;R42902;S42902;T42902;W42902;X42902);SI(ET(AA42902=FAUX;AB42902=VRAI);CONCATENER(B42902;C42902;D42902;E42902;G42902;"#NA";J42902;K42902;L42902;M42902;N42902;O42902;P42902;Q42902;R42902;S42902;T42902;W42902;X42902);SI(ET(AA42902=VRAI;AB42902=VRAI);CONCATENER(B42902;C42902;D42902;E42902;"#NA";"#NA";J42902;K42902;L42902;M42902;N42902;O42902;P42902;Q42902;R42902;S42902;T42902;W42902;X42902);CONCATENER(B42902;C42902;D42902;E42902;G42902;I42902;J42902;K42902;L42902;M42902;N42902;O42902;P42902;Q42902;R42902;S42902;T42902;W42902;X42902))))

C’est beau Excel hein :sac:

Sinon @douante le fichier déjà de base provient de je ne sais quel flux qui est mensuel, que j’ai du déjà à la base consolider. En vrai si j’avais su j’aurais foutu une clé unique sur chaque ligne avant que ma chef commence à faire les jeux de tests (extraire les lignes en fonctions de règles données). Donc de toute façon à part ce que je suis en train de faire je vois pas trop :hoho:


#137

Magnifique :hollande3:


#138

Dites, je cherche dans un tableau à reconstituer un champ “date” à partir d’une cellule fourre-tout : par j’ai en colonne J la cellule : “Mr X a déclaré sa situation le 24/05/2017 à Paris.”

Par quelle fucking miracle je peux faire une colonne K avec juste la date ?

Sachant aussi que la position de la date varie d’une ligne à l’autre suivant les cellules.


#139

=GAUCHE(DROITE(A1;19);10)

Par contre si les cases de la colonne concernées n’ont pas exactement autant de caractères, ça va coincer, et je n’ai pas de solution en tête :confused:


#140

Est ce que t’as toujours la même structure avant ou après la date ? genre “le XX à” ?

Est ce que le format de la date est toujours le même ?


#141

Je support que le nom du bonhomme et le lieu change a chaque fois. il faudrait que tu puisse avoir un champ avec le nom du mec et la civilité

Si on omet la ville après la date, y’a pas moyen de faire ça en plusieur colonne du genre:
Colonne A: Civilité
Colonne B: Nom
Colonne C: la phrase
Colonne D: len(A1)
Colonne E: len(B1)
Colonne F: len(C1)
Colonne G: F1-E1-D1
Colonne H: Left(A1;F1-(D1+E1))


Suivre @iunctisFR sur Twitter - Programme Partenaire amazon.fr : Amazon Prime - Amazon Prime Video - Amazon Audible